Administrator
  •  Admin
  • Advanced Member Topic Starter
2016-05-26T10:47:00Z
GeniusConnect 32bits
Requirements: Microsoft Outlook 2000, 2002, 2003, 2007, 2010, 2013, 2016, 2019 -32bits
Can be used on all 32 bits Outlook versions but will not support Non ASCII languages (Chinese, Japanese etc.).

GeniusConnect 32bits–Unicode
Requirements: Microsoft Outlook 2003, 2007, 2010, 2013, 2016, 2019 -32bits
The Unicode version implements support for all languages.

GeniusConnect 64bits–Unicode
Requirements: Microsoft Outlook 2010, 2013, 2016, 2019 -64bits

Download:
https://www.geniusconnec...geniusconnect-downloads/