lbertrand
2009-01-15T21:05:00Z
I am receiving an error on one user during synchronization. We are synchronizing many users successfully but this one fails - I believe it is because there is an apostrophe (single quote) in his last name.

Do you have any suggestions? Below is all the information that I think will help to answer the question.

Thank you very much.

The version we are using is:

Version:4-2000(400621) Multi-Byte build.Outlook version 11.0.0.8217

Here is the filter statement:

SchName = '{EXCHANGE_FOLDER_OWNER}' AND (DispCode <> 3 AND DispCode <> 5 AND DispCode <> 99)

I have tried altering this statement with different combinations of single and double quotes but I can't seem to get it to work.

Here is the error I get:

INFO:20090113 06:43:52 Folder: \\Mailbox - Tom O'Connor\Calendar
INFO:20090113 06:43:52 Connecting to database: FBSCTEL
INFO:20090113 06:43:52 Connected to database
INFO:20090113 06:43:52 Loading all items from database...
INFO:20090113 06:43:52 Scanning  existing Outlook items
WARNING:20090113 06:43:52 Can't determinate the record count. Error:Database call:
select count(*) from `Event` WHERE SchName = 'Tom O'Connor' AND (DispCode <> 3 AND DispCode <> 5 AND DispCode <> 99)


37000 [Microsoft][ODBC Microsoft Access Driver] Syntax error (missing operator) in query expression 'SchName = 'Tom O'Connor' AND (DispCode <> 3 AND DispCode <> 5 AND DispCode <> 99)'. (-3100)
INFO:20090113 06:43:52 Loading items
ERROR:20090113 06:43:52 Database call:
SELECT `BillingCode`,`Summary`,`AddDate`,`ChangeDate`,`SchSubject`,`SchBusyStatus`,`SchDuration`,`SchEnd`,`SchLocation`,`SchReminder`,`SchStart`,`SchLabel`,`Even
t_ID` FROM `Event`  WHERE SchName = 'Tom O'Connor' AND (DispCode <> 3 AND DispCode <> 5 AND DispCode <> 99)

37000 [Microsoft][ODBC Microsoft Access Driver] Syntax error (missing operator) in query exp
ression 'SchName = 'Tom O'Connor' AND (DispCode <> 3 AND DispCode <> 5 AND DispCode <> 99)'. (-3100)
INFO:20090113 06:43:52 Summary:
INFO:20090113 06:43:52 ->Successfully loaded 0 items(0 updated, 0 inserted, 0 unchanged)
INFO:20090113 06:43:52 Disconnecting from database
Administrator
2009-01-15T21:51:00Z
Please check latest 4.0.0.7 BETA 2:
http://support.geniusconnect.com/Posts/t222- 

It should fix the problem.