Langeman, Tim
2004-07-30T20:55:00Z
I get the following error when I try to "Store" a new Item in the database even though the record is successfully inserted into SQL Server:
"Unable to Save Item (SyncFolder)"

I also get an error when I try to modify a record in Outlook:
"A field on this form requires a value."

I am unable to "Load" items back into Outlook.

My config settings are as follows:
[Fields]
# Format: outlookfield=column,conversion
Business Address City=City,
Business Address Postalcode=Zip,
Business Address State=State,
Business Address Street=Address1,
Business Fax=Fax,
Business Phone=Phone,
Company (Name)=CompanyName,
Email=Email,
First Name=FirstName,
Initials=Initials,
Job Title=ContactTitle,
Last Name=LastName,
Mobile Phone=Cell,
Radio Phone=RadioID,
User field 1=ContactID,
User field 2=ContactTypeID,

[PrimaryKeys]
# Format: column=newstatement
ContactID=select (max(ContactID) + 1 ) from tblOutlookContact

[MandatoryKeys]
# Format: column=newstatement
ContactTypeID=select -1

-Tim
Administrator
2004-08-02T09:59:00Z
Are you using Custom Forms?
Langeman, Tim
2004-08-02T22:21:00Z
Yes, I think so.
There are custom fields, if that's what you mean.
Administrator
2004-08-02T22:29:00Z
"A field on this form requires a value."
This sounds like some mandatory field on your custom form.
Go to form designer and check properties of the fields
(Right click field->Properties->Validation)
Langeman, Tim
2004-08-02T22:37:00Z
Yes, one of the fields is required. I'll check with the client to see if I can either remove the requirement or satisfy it before saving to SQL Server.

Thanks