MyNextHome
2008-08-15T12:58:00Z
Hi,

we are experiencing poor performance with folders containing many items.
Sponsor
GeniusConnect documentation search (User Manual Downloads...)
Administrator
2008-08-15T12:58:00Z
Are you on Exchange?
MyNextHome
2008-08-15T12:59:00Z
Administrator
2008-08-15T13:03:00Z
This is probably cause by Microsoft, and has nothing to do with GeniusConnect. Try to uninstall GeniusConnect (or only disable the GeniusConnect sync), the performance will be still poor.

Please see Microsoft Article ID : 905803
http://support.microsoft.com/kb/905803 

Microsoft text:

Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server

SYMPTOMS
Microsoft Office Outlook 2003 users and Microsoft Office Outlook 2007 users experience poor performance when they work with a folder that contains many items on a server that is running Microsoft Exchange Server 2007, Microsoft Exchange Server 2003, or Microsoft Exchange 2000 Server. Additionally, Outlook users may receive one of the following messages:
Requesting data from Microsoft Exchange Server
Outlook is retrieving data from the Microsoft Exchange Server ExchangeServerName

CAUSE
This issue occurs when an Outlook user works with items in a folder that contains many items. Outlook must perform several operations against the Exchange server to retrieve the contents of a folder. Therefore, when there are many items in a folder, additional processing is required to respond to the Outlook requests.

RESOLUTION
You can help avoid poor performance in Outlook by carefully managing the number of items in folders, especially the Outlook folders that are heavily used. These folders include the Inbox, Calendar, Tasks, and Sent Items folders and any other heavily used folders.

The recommended number of items in a folder depends on several factors. These factors include the client's proximity to the server, the storage infrastructure, the load on the hard disks, the number of users, and the number of restricted views.

We recommend that you maintain a range of 3,500 to 5,000 items in a folder depending on the capacity of the Exchange Server environment. Additionally, you can create more top-level folders or create sub-folders underneath the Inbox and Sent Items folders. When you do this, the costs that are associated with index creation will be greatly reduced if the number of items in any one folder does not exceed 5,000.

The following list includes ways that you can help manage the number of items in folders:• Use folder hierarchies to help keep the number of items in a folder to the recommended values.
• Use mailbox manager policies.
• Use client-based archiving solutions.
• Use server-based archiving solutions.
• Use mailbox size limits.


MORE INFORMATION
The following list describes why more processing time may be required to retrieve the contents of the folder when there are many items in the folder: • Folder contents are stored in a table in the information store database. As the number of items increases, there is a corresponding growth in storage complexity. The storage mechanism for the Exchange store is the Extensible Storage Engine (ESE). ESE uses B+ trees data structures to store records. As the number of records increases, the potential number of disk I/O requests that are required to locate the information and traverse the B+ tree also increases. For more information, visit the following Microsoft Web site:
http://technet.microsoft...us/library/aa998171.aspx  (http://technet.microsoft.com/en-us/library/aa998171.aspx)
• As the number of items increases, the chance of the data being physically adjacent on the hard disk is greatly diminished. Therefore, more I/O requests are required than if the data were adjacent on the hard disk.
• Creating restricted views, or views of only a subset of items in a folder, requires more processing from the Exchange server. This behavior occurs because of the overhead that is associated with creating a search folder and populating the search folder with items that match the user's criteria. This process requires each item in the folder to be examined to determine whether each item should be put in the search folder. Therefore, when a folder contains many items, more time is required to create the view. By default, after a search folder is populated, the folder may exist for up to 40 days. For more information about search folders, visit the following Microsoft Web site:
http://technet.microsoft...us/library/bb124114.aspx  (http://technet.microsoft.com/en-us/library/bb124114.aspx)
• The presence of restricted views affects how quickly modifications can be made to the items in a folder. When a search folder is associated with another folder, more processing occurs when items are added, deleted, or updated in the other folder. This behavior occurs to determine whether the search folder must also be updated. When you establish many search folders, each change must be evaluated against all search folders to determine whether the search folders must also be updated.
• When more nonstandard properties are added to a folder view in Outlook, more remote procedure call (RPC) requests may be required to retrieve the property from the Exchange store. When a folder contains many items, more round trips are required to retrieve the data from the Exchange server.
• When you try to view a calendar folder, Outlook must locate all appointments in the specified date range. This requires at least two processing requests. The first request obtains all static appointments in the specified date range. The second request locates any recurring appointments that occur in the specified date range. The time that is required to process the second request is proportional to the number of items in the calendar folder. This behavior occurs because Outlook requests all recurring appointments. After the list of recurring appointments is received, each recurring appointment must be examined to determine whether the appointment occurs in the specified date range. When a folder contains many items, more time is required to process these requests.



APPLIES TO
• Microsoft Exchange Server 2007 Enterprise Edition
• Microsoft Exchange Server 2007 Standard Edition
• Microsoft Exchange Server 2003 Enterprise Edition
• Microsoft Exchange Server 2003 Standard Edition
• Microsoft Exchange 2000 Enterprise Server
• Microsoft Exchange 2000 Server Standard Edition

MyNextHome
2008-08-15T13:12:00Z
OK, I have uninstalled GeniusConnect, problem remains, what can we do? We can't remove items (MS suggest max. range of 3,500 to 5,000 items) but we need them.
Administrator
2008-08-15T13:29:00Z
You can check your network, exchange server and client PC hardware.
I know, the limit of 5000 items is ridiculous in Today's World, but this is Microsoft bad architecture. We can't change it!



Similar Topics